SDKs

To interact with a ledger from your application, you'll need an SDK. SDKs are available for Java, Node, and Ruby.

Use the language dropdown in the left-hand navigation of this page to switch the programming language displayed for all documentation.

Java

The Java SDK is available via the Maven Central Repository. Java 8, 9, and 10 are supported.

Maven users should add the following to pom.xml:

<dependencies>
  <dependency>
    <groupId>com.seq</groupId>
    <artifactId>sequence-sdk</artifactId>
    <version>[2.2,3)</version>
  </dependency>
</dependencies>

Gradle users should add the following to build.gradle:

compile 'com.seq:sequence-sdk:2.2'

Then use the following import statements in your code:

import com.seq.api.*;
import com.seq.http.*;
import com.seq.exception.*;

Node.js

The Node.js SDK is available via NPM. Node 4 or greater is required.

To install, add the following to your package.json:

{
  "dependencies": {
    "sequence-sdk": "~2.2.0"
  }
}

Then use the following import statement in your code:

const sequence = require('sequence-sdk')

Ruby

The Ruby SDK is available via RubyGems. Ruby 2.3 or greater is required.

To install, add the following to your Gemfile:

gem 'sequence-sdk', '~> 2.2', require: 'sequence'